Jump to content

Heater issue


Recommended Posts

Does anyone have any ideas on what this issue could be. When I set the temperature to less the 25 on the climate control i dont seem to get any warm air then at 25 air is warm/hot.

This is manual mode with air con off. In AUTO it seems to do its job. Pretty sure it used to be warm at 22 C previously.

 

Coolant level is fine and engine warms up to operating temperature fine so doubt its the thermostat. Could be a temperature sensor somewhere or is this normal behaviour. Car is a gen 2.

Edited by mc5
Link to comment
Share on other sites

There's a temperature sensor in the cabin that will control the outputted heat from the climate control.  If the sensor is faulty then it will do as you describe.

 

The cabin sensor is misreading, which causes the CC to think the cabin temp is 25° and it's trying to maintain that temperature.  The temp that you set on the CC is to target/maintain that temp within the cabin - not to set the output temperate of the CC.

Link to comment
Share on other sites

Mine is doing the same.

Works fine at the start of a journey then starts to cool down so I end up with it at 28C (normally have a car at 19C)

I turn it right down to cool then back up to 19C and it warms up again only to cool down again as time goes on.

No big deal but would be good to get it fixed.

Link to comment
Share on other sites

1 hour ago, Aaron said:

There's a temperature sensor in the cabin that will control the outputted heat from the climate control.  If the sensor is faulty then it will do as you describe.

 

The cabin sensor is misreading, which causes the CC to think the cabin temp is 25° and it's trying to maintain that temperature.  The temp that you set on the CC is to target/maintain that temp within the cabin - not to set the output temperate of the CC.

Seemed to ok tonight very odd. So when set to manual mode if say set to 22 but the cabin is at a warmer temp it will start sending cooler air. Can understand it doing this in auto but not in manual mode. Do you know where the sensor is located is it in the control panel as the manual mentions it has one there.

Link to comment
Share on other sites

Manual mode just means that the climate control isn't automatically controlled and self adjusting (fan speed, blower direction) - the temperate control is always target-based.

 

Not sure where the switch is to comment, I'm afraid.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.